The incident has been resolved. We apologize for any inconvenience caused and thank you for your understanding.
Posted Mar 03, 2026 - 15:54 CET
Identified
We wish to inform you that our application is currently experiencing instability issues. We recommend clearing your browser cache (via your browser settings or using Ctrl+Shift+R) to restore access while our teams work to resolve the problem.
We apologize for any inconvenience caused and thank you for your understanding.
Posted Mar 03, 2026 - 15:39 CET
This incident affected: Application (app.pennylane.com).