Pennylane application disruption

Incident Report for Pennylane

Resolved

The incident is now resolved.

Intermittent disruptions of several services started at 10h55, causing the application to be unavailable between 16h53 and 17h00 while teams were applying mitigations.

We apologize for any inconvenience caused and thank you for your understanding and patience.
Posted Jul 20, 2026 - 19:03 CEST

Monitoring

The issue has been identified, access to our application is fully operational again.

Our teams are continuing to monitor the infrastructure.
Posted Jul 20, 2026 - 17:09 CEST

Investigating

We are currently experiencing an incident that is affecting the availability of our platform.
Our technical teams are actively working to identify and resolve the issue as quickly as possible.

We apologize for any inconvenience caused and thank you for your understanding and patience.
Posted Jul 20, 2026 - 16:56 CEST

Update

Our teams continue to monitor the situation.
Posted Jul 20, 2026 - 16:36 CEST

Monitoring

The issue has been identified, impacted services are recovering. Our teams are monitoring the results.
Posted Jul 20, 2026 - 13:01 CEST

Investigating

We would like to inform you that our application is experiencing issues/slowdowns for several features (invoice parsing & creation, email notifications).
Our teams are currently investigating to resolve this behavior.
We apologize for any inconvenience caused and thank you for your understanding.
Posted Jul 20, 2026 - 11:30 CEST
This incident affected: Application (app.pennylane.com).