Pennylane application disruption (Academy)

Incident Report for Pennylane

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 11:18 CEST

Investigating

We want to inform you that access to our Academy platform is currently unavailable.
Our teams are currently working to resolve this issue.

We apologize for any inconvenience caused and thank you for your understanding.
Posted Jun 08, 2026 - 11:12 CEST
This incident affected: Academy (academy.pennylane.com).